Traditional Chinese (zh_TW) translation group

Here is the Traditional Chinese (zh_TW) translation group. I’m evaluating Indico for our open source conferences in Taiwan.

Hey!

I have seen that you have already finished translating Indico. As a first step I would recommend to create an account on https://transifex.com and join our Indico team there. We already have someone actively translating Indico to Chinese there :wink:

Regards,
Michal

Hi,

I already have an account on Transifex with my email address. Could you please add me into the Indico team? Thanks.

For some reason I can’t access your profile on Transifex. Can you please send a join request to the Indico Team?

I need to send language request for Chinese(Taiwan) first then join the team. I’ve seen that the language has been added and just sent the join request. :slight_smile:

1 Like

Finally! I have done >98% of core translation and uploaded to Transifex!


And just found that 2.2.5 was released 2 days before :cry::cry::cry:

There shouldn’t be more than a few messages changed since the last 2.2.x versions

I hope the plural form problems have been solved so that I can use Traditional Chinese.

Will try after upgrading…

yes, they have been fixed

I did the following actions:

  • upgraded to 2.2.5 including plugins and db
  • delete all the files under ~indico/cache
  • copy my po files to translations/zh_TW/LC_MESSAGES (the zh_Hant_TW symlink is still there)
  • run indico i18n compile-catalog and indico i18n compile-catalog-react
  • systemctl restart indico-celery.service

But I still get the following error in Room booking system:

Uncaught Error: Placeholder '{number}' got no value
    at e (index.js:169)
    at index.js:177
    at Array.map (<anonymous>)
    at e (index.js:176)
    at S (index.js:195)
    at Function.value (index.js:394)
    at Module.<anonymous> (RoomEditModal.jsx:393)
    at a (bootstrap:84)
    at Object.<anonymous> (index.js:1)
    at a (bootstrap:84)

I also tried cleaning the browser cache and using privacy mode.

Any suggestion to debug?

Most likely your PO files still have wrong data for “Weekly” and/or “Monthly” (which was previous reused in a singular-only and singular+plural case, causing the error). We added context to distinguish them but if you use the same PO file as before you still have the error.

To update your PO files either re-download them from transifex or update them locally using indico i18n update-catalog-react (not sure if that works outside a development setup though).

Yes, thanks. Finally I got Traditional Chinese works!

The updated translations will be packed along with 2.2.6 or 2.3.0, right?