Translations download error

Hello, I have a problem downloading translations. I created a ~/.transifexrc file but when I try to get translations using tx pull -a or selecting a specific language I get an error. Forbidden Authentication failed. Please make sure your credentials are valid . Do I need to be a language administrator to download it? Please help.

Did you put API credentials in your .transifexrc? This is what I have (API key obscured of course):

api_hostname =
hostname =
password = 1/***************
username = api

I have the same ~/.transifexrc file set up.

Hi Pawel,

Considering the API key is correct or you’ve already tried generating a new one. I can only recommend running the initialisation again: tx init --skipsetup. After deleting your current ~/.transifexrc file.

It will ask for your API token and automatically install it. You can also pass it as an enviroment variable before the command export TX_TOKEN=***.

Please let me know if this doesn’t work.

I have tried it many times. You can see that when I enter the wrong token, it asks me to re-enter it and when I enter the correct one, it accepts it, but returns an error.

If I understand correctly how transifex works you can only download translations when you are part of project and maybe even specific language group. I think that all translations should be periodically dumped to repository by someone who have access to it. But for now, can you maybe check join requests on transifex and accept all awaiting people, so we can download all necessary files via the API/client?