[SOLVED] Problem installing 2.0 on old machine, pyatom < 1.4

Hi all

We are planning to migrate from 1.2.1rc11 to 2.2

We were hoping not to need to change the whole operating system.
We are currently running happily version 1.2 on OpenSuSE 13.1 which has support for python 2.7.6

I managed all preparation steps except that postgresql is version 9.2, so I already suspect nothing might work, according to the install pages 9.6 is needed. However I am not yet at the database conversion level.

I didn’t manage to get past the indico python install, I get this error after the command

python install 'indico<2.1'

ERROR: Could not find a version that satisfies the requirement pyatom==1.4 (from indico<2.1) (from versions: 0.0.2, 0.0.3)
ERROR: No matching distribution found for pyatom==1.4 (from indico<2.1)

What’s the minimum python2 requirement for indico 2.2? Or maybe I am doing something else wrong?
pip update seems to bring down pyatom 0.0.3 and no more.


Please see error using indico-migrate to migrate from indico 1.2 for a solution for the pyatom problem.

1 Like