Error using indico-migrate to migrate from indico 1.2

Hello dear administrators and developers of indico

I perform the following steps in this guide

I tried to migrate to the indico version 2.0 but I generated the pyatom 1.4 error. I read in forums that this library was not longer available for that version so I tried to install version 2.1.9, but when i was trying to install the indico-migrate package with pip but I get the same pyatom 1.4 error

you have the pyatom 1.4 library to install and execute this step? or is there another way to perform the migration from version 1.2?

Luckily there are still some mirrors on the internet which have this package. You can run this command to install it; afterwards installing indico 2.0 should work:

pip install'

Thanks for the help

the link worked for me and I executed the migration command with the documentation suggested to get to version 2.0 of indico, but the resulting site looks like this:

the style was lost and additionally it shows me the following message “Update your browser to view this website correctly. Update my browser now” but I’m using the latest version of the mozilla and chrome browser.

Most links after migration don’t work, should I try again to run the indico-migrate command with other arguments? or what is the suggestion to detect the reason why the articles did not pass, some lines of the migration.log file are:


Update to 2.2 - the webserver config from the install guide won’t work with <2.2, so no CSS, JS, etc. gets loaded (which also results in the outdated-browser message always being visible).

Again thanks you for the information.

the update to version 2.2 worked, now I’ve the styles working correctly

1 Like

Same problem here!!

I need to migrate from indico 1.1.2
So first trying to install indico 2.0 as decribed in several posts.
Installed a new OS (Ubuntu 18.04.3 LTS)
and follow the instructions from
after the command: pip install ‘indico<2.1’
I get the same error even after the above mentioned pip install of pyatom
ERROR: Could not find a version that satisfies the requirement pyatom==1.4 (from indico<2.1) (from versions: none)
ERROR: No matching distribution found for pyatom==1.4 (from indico<2.1)

Any help appreciated.

See my answer earlier in this thread:

I already did this but I get still the error.

What was the output from running the comment in the post I linked? Afterwards you shouldn’t get a message about pyatom missing…

pip install your-link
Collecting your- link
Requirement already satisfied (use --upgrade to upgrade): pyatom==1.4 from in /usr/local/lib/python2.7/dist-packages
Building wheels for collected packages: pyatom
Running bdist_wheel for pyatom … done
Stored in directory: /home/guest/.cache/pip/wheels/e3/8b/49/2397e43baa36c9f80110d9423eb6ed328dbbaf71977c366752
Successfully built pyatom

You need to be inside the indico virtualenv when installing this…

Oke, that was the solution.
Thanks a lot.

Hello again

I tried to repeat the procedure again on another machine with the same characteristic and with the version of indico 1.2.
I executed all the steps until to reach the execution of the indico-migrate command but on this occasion the following error appears:

Any idea about the error?

Thank you very much

Sounds like something is wrong with your ZODB’s Data.fs. I’d check the ZODB docs if there’s any info on recovering from this issue…

If it worked on the old machine, check if the file was properly copied; I guess such errors could happen if the file wasn’t fully copied or got corrupted for some reason.

Thanks for answering

I indeed the ZODB database was corrupt.
I restored a backup of all ZODB files:


in the /opt/indico-legacy/db/ directory

and I re-executed the indico-migrate command executing correctly.