Indico Setup Wizard

I’m following through the setup instructions and have been able to figure everything out so far, however, I don’t know what to put for this:

Enter the SQLAlchemy connection string to connect to your PostgreSQL database.
For a remote database, use postgresql://user:pass@host/dbname
PostgreSQL database URI: postgresql://user:pass@host/indico

If I leave it as default, I get:

Invalid database URI: could not translate host name “host” to address:
Temporary failure in name resolution

If I change host to my hostname, I get:

Invalid database URI: could not connect to server: Connection refused
Is the server running on host “testhost” ( and accepting
TCP/IP connections on port 5432?

Did you install Postgres locally? Because if there’s a running Postgres server it should propose postgresql:///indico. If not, then indico assumes you know the connection data for an external database - the default of postgresql://user:pass@host/dbname is just an example to show the format…

I didn’t at first, but it is now locally installed. Running the wizard still proposes the same remote string. Changing it to postgresql:///indico results in:

Invalid database URI: FATAL: role “indico” does not exist

/etc/init.d/postgresql status

● postgresql.service - PostgreSQL RDBMS
Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor preset: enabled)
Active: active (exited) since Wed 2021-09-22 08:45:15 EDT; 1h 16min ago
Main PID: 919 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 2272)
Memory: 0B
CGroup: /system.slice/postgresql.service

You need to follow the steps from the setup guide where you create the user and database…

I started over with a clean install and followed the instructions again. I got past the postgres install and all is well there. The problem seems to be with setting the correct domain name in the setup wizard. If I use the hostname, it works, but only as a local user. If a user tries to connect from another comptuer, it says “https://myhostname” can’t be found.

If I put in the IP address instead of hostname, I get " Invalid URL This Indico instance can only be accessed via". It’s obviously getting to the server because it’s an Indoco error message.

I don’t have a FQDN yet, as I am on a University campus and it takes time to request.

Will a FQDN resolve this issue? I just want to set it up in a test environment that my colleagues on campus can check out.

Yes. You can edit your /etc/hosts for testing or simply put the IP address in BASE_URL instead of the future FQDN… The address in the request just needs to match the BASE_URL.