error using indico-migrate to migrate from indico 1.2

Hello dear administrators and developers of indico

I perform the following steps in this guide

https://docs.getindico.io/en/stable/installation/upgrade_legacy/

I tried to migrate to the indico version 2.0 but I generated the pyatom 1.4 error. I read in forums that this library was not longer available for that version so I tried to install version 2.1.9, but when i was trying to install the indico-migrate package with pip but I get the same pyatom 1.4 error

you have the pyatom 1.4 library to install and execute this step? or is there another way to perform the migration from version 1.2?

Luckily there are still some mirrors on the internet which have this package. You can run this command to install it; afterwards installing indico 2.0 should work:

pip install 'https://artifactory.corp.mongodb.com/artifactory/api/pypi/pypi/packages/ee/a3/ca8d9d4255e71d12c2f88523f431b88868ec73c2fdeae7eca8e64ae0908e/pyatom-1.4.tar.gz#sha256=dbf05b5c30138ac720acf2cb77af819477e554607fa12ade0d8bb764c5756bf3'

Thanks for the help

the link worked for me and I executed the migration command with the documentation suggested to get to version 2.0 of indico, but the resulting site looks like this:

the style was lost and additionally it shows me the following message “Update your browser to view this website correctly. Update my browser now” but I’m using the latest version of the mozilla and chrome browser.

Most links after migration don’t work, should I try again to run the indico-migrate command with other arguments? or what is the suggestion to detect the reason why the articles did not pass, some lines of the migration.log file are:





imagen

Update to 2.2 - the webserver config from the install guide won’t work with <2.2, so no CSS, JS, etc. gets loaded (which also results in the outdated-browser message always being visible).

Again thanks you for the information.

the update to version 2.2 worked, now I’ve the styles working correctly

1 Like

Same problem here!!

I need to migrate from indico 1.1.2
So first trying to install indico 2.0 as decribed in several posts.
Installed a new OS (Ubuntu 18.04.3 LTS)
and follow the instructions from https://docs.getindico.io/en/latest/installation/production/debian/apache/
after the command: pip install ‘indico<2.1’
I get the same error even after the above mentioned pip install of pyatom
ERROR: Could not find a version that satisfies the requirement pyatom==1.4 (from indico<2.1) (from versions: none)
ERROR: No matching distribution found for pyatom==1.4 (from indico<2.1)

Any help appreciated.

See my answer earlier in this thread:

I already did this but I get still the error.

What was the output from running the comment in the post I linked? Afterwards you shouldn’t get a message about pyatom missing…

pip install your-link
Collecting your- link
Downloading https://artifactory.corp.mongodb.com/artifactory/api/pypi/pypi/packages/ee/a3/ca8d9d4255e71d12c2f88523f431b88868ec73c2fdeae7eca8e64ae0908e/pyatom-1.4.tar.gz
Requirement already satisfied (use --upgrade to upgrade): pyatom==1.4 from https://artifactory.corp.mongodb.com/artifactory/api/pypi/pypi/packages/ee/a3/ca8d9d4255e71d12c2f88523f431b88868ec73c2fdeae7eca8e64ae0908e/pyatom-1.4.tar.gz#sha256=dbf05b5c30138ac720acf2cb77af819477e554607fa12ade0d8bb764c5756bf3 in /usr/local/lib/python2.7/dist-packages
Building wheels for collected packages: pyatom
Running setup.py bdist_wheel for pyatom … done
Stored in directory: /home/guest/.cache/pip/wheels/e3/8b/49/2397e43baa36c9f80110d9423eb6ed328dbbaf71977c366752
Successfully built pyatom

You need to be inside the indico virtualenv when installing this…

Oke, that was the solution.
Thanks a lot.