Upgrading from 2.2.8 > 2.3+

Hello Indico community,

I seem to be running into a problem changing my Indico Version in Docker.

Right now my .yml file has: image: getindico/indico:2.2.8

Which works perfectly fine, but when I switch to image: getindico/indico:2.3+ I run into all kinds of UI bugs on the site, do you know where else typically I would have to make upgrades in docker? I know this is kind of vague but maybe other people ran into similar issues.


Just FYI, 2.3 isn’t supported anymore either. I suggest to go straight for getindico/indico:3.1 instead.

I would not expect UI issues to happen there in any case though, since the nginx configs that needed updating at some point (but iirc that was from 2.1 to 2.2) are part of the docker image…

Okay, I think I get the same bugs at 3.1 as well but I’ll make that swap, I only did 2.3 because I thought it would be close.

I think some details on what’s breaking (check e.g. browser devtools if you get any 404s on static assets) would help figure out what’s going wrong :slight_smile:

This error does not appear when I run 2.2.x

This is what I see when I switch back in my docker-compose.yml back to 2.2.8

Do you have any old data in docker volumes by any chance?

This is what is being edited

Uhhh I’m not sure, I run docker-compose down every time I run it so I can’t tell.

This is everywhere the .yml says volume

Hi @foreandr,

I’m investigating this and I’ll come back as soon as I know more.

Most probably it is the static-files volume thats needs recreation. A normal docker-compose down does not clean volumes, instead they are persistent. But beware , don’t run blindly docker-compose down -v
as you are using named volumes for archive as well, so that needs to be backed up before. And once a volume is attached externally the image-provided volume is shaded.
One solution would be to create a new named volume static-files-v3.1.x and use that instead of static-files. Then it should get recreated with fresh content.

The alternative is the approach i am using: build a matching nginx-image that gets the static files copied instead.


FROM  indico... as indicobase

FROM nginx:latest

COPY --from=indicobase /opt/indico /opt/indico

Do you mean change where it says “static-files:” to "static-files.-v3.1x?

Or am I supposed to put that static folder on the left somewhere underneath that volume section
Presumably with the new static3.x/Dockerfile

edit:or did you mean in indico-web: volumes, link it to another version of folder?

Hello so bpedersen2 Seems to have solved the problem, I no longer have any UI errors, I have other errors related to SQL, but that is related to something else, so I may post that in another thread if I have more questions, thank you all!

Great! That makes sense. I was just running a fresh new docker environment but couldn’t reproduce the problem. Thanks @bpedersen2

Regarding the errors, perhaps you’re missing some database upgrade?