Unable to upgrade the Indico version from 2.x to 3.x

Hello Team,

We are trying to upgrade the version from 2.x to 3.x but getting dependencies issues while we upgrade it through python v3 for reference PFA, if someone helps on this it will be very helpful for me.

Thank you

Sorry, the lack of context in your screenshot (please don’t use screenshots but text for errors in the future) makes it very hard to help you. And the fact that you are working as root seems to indicate you aren’t following our setup guide… not following our setup guide is fine if you prefer to deploy things differently, but of course we can only take guesses what’s going wrong in such a case (and we also assume that people who divert from the setup guide are much more familiar with Linux administration and Python packaging than someon who just follows it…)

In any case, if this particular ipython version can’t be installed there’s a good chance your Python version is too old. It has “Requires: Python >=3.7” in its metadata and just FYI, Indico requires Python 3.9.

Anyway, if you have specific questions/problems related to installing Indico, I’m more than happy to help you with them.

thank you for your reply,

can you please help me to upgrade the indico version, right now we have indico==2.3.5 but we need v3.1.

we have tried to upgrade it with the below commands:

#pip install -U indico
#pip install -U indico-plugins
#indico setup upgrade-python

Please see this part of the docs. Upgrading from v2 to v3 is NOT just a simple pip install -U indico due to the major changes (Python 2 to Python 3).


yes, we follow the same procedure with the given link and that’s why I shared the commands because we are facing issues of dependencies in these commands.

and we are running indico on CentOS 7 with python3

In your screenshot I see you running pip install as root. This is certainly not in the setup guide.

And CentOS 7 does NOT have a recent Python 3 version included - you must use pyenv as suggested in the docs to get Python 3.9.

@Chitranjan_Kumar For what is worth, we upgraded our v2 instance at the beginning of the week from CentOS 7 to CentOS Stream 8 (not recommended in the guide!) but following strictly the upgrade guide otherwise (with the fresh install approach and dump/restore of the database). It worked like a charm, including Shibboleth integration. I was really impressed.



Hello @jouvin

As per your suggestion, I have tried to install the new version on the new python environment and install its all dependencies then restored the old DB on the new one which we use for our old version, replace entries from indico-celery.service file but still on the website it’s showing old version and getting some Database error:

Something went wrong
There was a database error while processing your request.
Go to the main page

So please suggest me what can be the reason for this error.

Did you do indico db upgrade after installing the latest version?

@Chitranjan_Kumar I summarized what I did in my previous post but my suggestion is to follow very carefully the upgrade instructions, Upgrade — Indico 3.1.1-dev documentation that explains all the steps that must be done a little bit differently from the vanilla installation.

yes I have run this command but still shows the same error

Check logs/indico.log for the error.

Sorry, there was no error logs generated on the indico.log file

If you get “there was a database error processing your request” there must be something in /opt/indico/log/indico.log as well unless you manually changed the logging config to not log anything there… Can you please double-check there?

Something else you can test to make sure DB connectivity works: run indico shell and then paste the following snippets:


The output (if it returns an object) is not interesting, but if you get an error then the error message will be interesting.

I managed to upgrade from v2.3.3 to v3.1 without a problem. Migrated from Ubuntu 16.04 (With postgresq-9.6 python-2.7) to Ubuntu 20.04 (Fresh install with python-3.9.10 and postgresq-13) and dumped/imported DB without a problem. Was getting an error after that but solved it with “indico db upgrade” and everything worked just fine.