Hello, I am trying out the new ‘authlib’ provider found in Flask-Multipass 0.3.dev5.
So I went ahead and run
pip install -U --pre Flask-Multipass[authlib]
inside the virtualenv (of Indico installation via pip).
It then, of course, raise the exception
pkg_resources.ContextualVersionConflict: (Flask-Multipass 0.3.dev5 (/opt/indico/.venv/lib/python2.7/site-packages), Requirement.parse('Flask-Multipass<0.3-dev,>=0.2'), set(['indico']))
Because Indico requires non-dev version of Flask-Multipass.
This could be easily fixed if I clone Indico directly from github and edit the setup.py file. But I am looking for a way to edit this directly in the installed package. I know this is not a best practice, but is it possible to do so?