Trying out 'authlib' provider in Flask-Multipass 0.3.dev5

Hello, I am trying out the new ‘authlib’ provider found in Flask-Multipass 0.3.dev5.
So I went ahead and run

pip install -U --pre Flask-Multipass[authlib]

inside the virtualenv (of Indico installation via pip).

It then, of course, raise the exception

pkg_resources.ContextualVersionConflict: (Flask-Multipass 0.3.dev5 (/opt/indico/.venv/lib/python2.7/site-packages), Requirement.parse('Flask-Multipass<0.3-dev,>=0.2'), set(['indico']))

Because Indico requires non-dev version of Flask-Multipass.

This could be easily fixed if I clone Indico directly from github and edit the file. But I am looking for a way to edit this directly in the installed package. I know this is not a best practice, but is it possible to do so?

For testing/development I would recommend to just use git master instead of 2.2.

But if you do want to stay on 2.2 for now, edit indico.egg-info/requires.txt and remove/patch the Flask-Multipass line in that file in case of a dev setup.

But since the path in your error appear to be for a production setup, the file to edit is /opt/indico/.venv/lib/python2.7/site-packages/indico-2.2.8.dist-info/METADATA