[Solved] Installation error print statement missing parantheses

Hi, I am trying to install indico but I get the following error. I am using python 2.7. And it’s downloading an old version of indico, don’t know why.

Please follow the install guide. sudo pip install indico is not something you should be doing at all when installing Indico.

Also, since your pip is using a “cached” version of the file it looks like a very old machine that had 1.2 downloaded/installed at some point? If yes, I recommend you to use a fresh server/VM to install the latest Indico version instead of one that still has all the stuff from legacy installed…

In the install guide you sent there are these lines

source ~/.venv/bin/activate
pip install -U pip setuptools
pip install indico

Also, we can’t change the server. What should we do ? Thankyou.

There’s no sudo in the guide… :wink:

If you have your legacy indico version in /opt/indico then you should probably move that away to somewhere else or replace all occurrences of /opt/indico when following the install guide with something else, like /opt/indico2.

ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/opt/indico/.venv/lib/python2.7/site-packages/vine’
Consider using the --user option or check the permissions.

Sounds like /opt/indico is owned by root and not the indico user… Please consider my last suggestion of using a new user and/or homedir if indico and/or /opt/indico are used by legacy indico.

it worked, thankyou.