Registration page configuration always blank


#1

When i try to configure a registration page it is always blank with the only option of ‘Back’.

reading another post i have edited the base_url in indico.conf to be the same as the one i use to access the site and this hasn’t worked.
The error in my console suggests that the cal l to ajax has been blocked because i am using https - apart from changing my site to being http how do we get around this?

Mixed Content: The page at 'https://test-events.geant.org/event/10/manage/registration/5/form/' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://test-events.geant.org/js/indico/modules/registration/form/tpls/registrationform.tpl.html'. This request has been blocked; the content must be served over HTTPS.
angular_f63f2c32.min.js:333 Error: Failed to load template: xxxxs://test-events01.geant.org/js/indico/modules/registration/form/tpls/registrationform.tpl.html
    at angular_f63f2c32.min.js:275
    at angular_f63f2c32.min.js:513
    at wrappedErrback (angular_f63f2c32.min.js:443)
    at wrappedErrback (angular_f63f2c32.min.js:443)
    at angular_f63f2c32.min.js:448
    at Object.$eval (angular_f63f2c32.min.js:484)
    at Object.$digest (angular_f63f2c32.min.js:482)
    at Object.$apply (angular_f63f2c32.min.js:484)
    at done (angular_f63f2c32.min.js:520)
    at completeRequest (angular_f63f2c32.min.js:537)

#2

#4

Did you reload uWSGI after editing the config? Otherwise it doesn’t take the change into account.


#5

sudo systemctl restart uwsgi


#6

Chrome - failed

Firefox (just tried) - working

Not good - but at least i can move on - thanks for your help. Mark.


#7

If you restarted it should work. Try clearing your browser’s cache. I can’t check if your instance serves correct data now since it doesn’t seem to be available from outside your organization.

PS: Since you posted your SECRET_KEY please change it; someone malicious could use this to login as any user. If it’s a test instance it’s not a huge issue but if you reused the same secret key for a production setup, that’d be somewhat bad.


#8

ops - cheers - will do


#9

cheers - its me being stupid - didn’t think of cache!!! - yes, working in chrome now, so original fix suggestion worked fine.