Questions about Indico uploading files

When we upload the PPT named in Chinese, it cannot be uploaded. However, when we named PPT in English, it didn’t have a problem. We hope to upload PPT named in Chinese. Do you have any solution? Thank you very much!

Which Indico version do you use? Do you get any error?

The version of indico we used was 1.2, and there was no response after clicking “Create Resource”.

In version 3.0, it is possible to upload Chinese named files. This is not possible in version 1.2.

1.2 is MASSIVELY outdated (about 7 years old). You need to upgrade ASAP.

And yes, anything starting with v2.0 (which is also more than 4 years old) supports such filenames just fine; but of course you should install the latest stable version which is currently 3.1.

Note that if you want to preserve data you need to use 2.0 as a step where you can import the data from v1.2.

Ok, Thank you for your answer.

I have one more question to ask you. When using version 3.0, we used Shibboleth for SSO authentication, however, it appeared on the New User registration page (Create a new Indico Profile, to show the Family name is gibberish. We’re trying to figure out why, Found in/opt/indico /. Venv/lib/python3.9 / site - packages/flask_multipass/will/shibboleth. py → def _shibboleth_callback(self) : attributes = {k: V for k, v in mapping if k.startswith(self.attrs_prefix)} ,the Chinese character in “attributes” is garble, I guess it is latin1 character encoding, but the problem is still not solved after changing the encoding.

The data needs to be utf8-encoded; that’s what indico and flask-multipass expects. So maybe something needs to be changed in the shibboleth config?