Plugin Error when transferring to newly installed Indico

The plugin(not installed by me) worked fine with the older installation(ver 2.2) of Indico.

I installed the latest 2.3 to different path and tried to install the plugin my self.

  1. Installed the plugin as module to the python virtual env I am using

indico-plugin-invoices @ file:///home/user/dev/indico_2.3/plugins/invoices (from pip freeze)

  1. Tried building assets with:
    python bin/maintenance/build-assets.py plugin --dev …/plugins/invoices/
    which gives error:
    subprocess.CalledProcessError: Command '['python', 'bin/maintenance/dump_url_map.py', '--output', '/home/user/dev/indico_2.3/plugins/invoices/url_map.json', '--plugin', 'invoices']' returned non-zero exit status 1

When I run
“python bin/maintenance/dump_url_map.py --plugin invoices” the exception is

File “bin/maintenance/dump_url_map.py”, line 33, in get_rules
‘PLUGINS’: plugins})
File “/home/user/dev/indico_2.3/src/indico/web/flask/app.py”, line 379, in make_app
raise Exception(‘Could not load some plugins: {}’.format(’, '.join(plugin_engine.get_failed_plugins(app))))
Exception: Could not load some plugins: invoices

In plugin setup.py file entry point is defined as:
entry_points={‘indico.plugins’: {‘invoices = indico_invoices.plugin:InvoiceManagementPlugin’}}

check indico.log for the actual error why loading the plugin failed.

my guess would be that it needs to be updated to work on 2.3…

Nothing in data/logs/indico.log

I will try to create a blank new plugin based on the tutorial and the existing plugins.

Is the plugin actually installed? indico setup list-plugins to see the available plugins.

If yes, and enabled in indico.conf, see if indico shell fails as well when you try to run it.

Thank you.
" indico setup list-plugins" gave me the actual error in plugin source that was the problem.

After fixing it now the same command is working, also building assets finished successfully.

Now I am getting the following error when I try to access the home page:

“OSError: [Errno 2] No such file or directory: ‘/home/user/dev/indico_2.3/env/local/lib/python2.7/site-packages/indico_invoices/static/dist/manifest.json’”

I am running both “./bin/maintenance/build-assets.py indico --dev --watch” / ./bin/maintenance/build-assets.py plugin …/plugins/invoices/ --dev --watch
on separate terminals.

Restart the assets builder for the plugin. It’s probably still broken from the earlier error, and unless files in there change it won’t rebuild anything.

Works fine now. Thank you.