Not backward compatible change in uwsgi-plugin-python package name


#1

Hi, recently there was an update in the referred python package, so the installation for centos is not longer working. According to the release there is no backward compatibility, the new package is uwsgi-plug-in-python2…not sure how to proceed. Thanks for your reply.


#2

Just use uwsgi-plug-in-python2, that should work fine. Isn’t uwsgi-plug-in-python aliased to that package though?


#3

Thanks for your prompt reply.

Nop. It doesn’t work. No alias apparently but there is a patch, not sure how it could affect the installation.

Here the details: https://bugzilla.redhat.com/show_bug.cgi?id=1628147

Regards,

DdM


#4

To me that sounds like the only problem is that installing uwsgi-plug-in-python will fail - but if you install uwsgi-plug-in-python2 it should work fine.


#5

Actually, the plug-in is not loaded as you can see in the status for the service. I’m assuming it is mandatory to start the whole Indico application. In advance, thanks for your response.

systemctl status uwsgi.service
● uwsgi.service - uWSGI Emperor Service
Loaded: loaded (/usr/lib/systemd/system/uwsgi.service; enabled; vendor preset: disabled)
Active: active (running) since Tue 2018-11-06 15:57:59 -03; 22s ago
Main PID: 14009 (uwsgi)
Status: “uWSGI is ready”
CGroup: /system.slice/uwsgi.service
├─14009 indico uWSGI master
├─14010 indico uWSGI worker 1
├─14011 indico uWSGI worker 2
├─14012 indico uWSGI worker 3
└─14013 indico uWSGI worker 4

Nov 06 15:57:59 eventos.mydomain systemd[1]: Starting uWSGI Emperor Service…
Nov 06 15:57:59 eventos.mydomain uwsgi[14009]: [uWSGI] getting INI configur…i
Nov 06 15:57:59 eventos.mydomain uwsgi[14009]: open("/usr/lib64/uwsgi/pytho…]
Nov 06 15:57:59 eventos.mydomain uwsgi[14009]: !!! UNABLE to load uWSGI plu…!
Nov 06 15:57:59 eventos.mydomain systemd[1]: Started uWSGI Emperor Service


#6

Try plugin = python2 instead of plugin = python in /etc/uwsgi.ini


#7

Again thank you for your reply.

It seems like was just a matter of restarting the whole services after installing the new package (uwsgi-plug-in-python). I left plugin = python in the uwsgi.ini file. Now it’s working.

Best,

DdM