Need help updating from Indico 2.2.5

We are running Indigo 2.2.5 on CentOS 7.8. Today I made a back /opt/indico by tar and tried to update to the Indigo 2.3. But it failed and Indico stopped working.

I put the update log and apache error log at the url of

I restored Indigo from the tar backup and now it is working well as Indigo 2.2.5.

Is there any suggestions ? Thank in advance.

Did you get any errors? Have you tried restarting uwsgi instead of just triggering a reload? Any errors when trying to run e.g. indico shell?

Also, your pip is quite old, I would recommend doing a pip install -U pip setuptools before upgrading indico itself.

I did not get any errors. I also rebooted the server after update, but still not working. I also tried to do “systemctl daemon-reload” “systemctl restart uwsgi.service” but still not working.
Therefore, I restored from the tar backup.

What I see missing in the log are the “indico db upgrade” steps. There were schema changes between 2.2 and 2.3

And you did also not upgrade plugins.

And don’t forget to do a db backup before as well.

I put other logs, /opt/indico/log/indico.log and celery.log.

All those errors indeed come from not having upgraded the database…

Also, how exactly did things “not work”? Were you getting timeouts? A blank page? A broken indico page?

Thank you for the suggestions. I did not update the DB. For the second time, I updated the pip first and then “pip install -U indico”. However other error was displayed.

ERROR: After October 2020 you may experience errors when installing or updating packages. This is because pip will change the way that it resolves dependency conflicts.

We recommend you use --use-feature=2020-resolver to test your packages with the new resolver before it becomes the default.

So I stopped here and restored from the tar backup again.
Can I continue to update DB, with this error ?
(I will continue to try tomorrow)

And don’t forget to do a db backup before as well.

Thanks. I did “pg_dump indico > …” everyday by cron.

Also, how exactly did things “not work”?

Internal Server Error, or Service Unavailable at the client browser.

That’s not an error by itself. The problem is that you still have indico-migrate installed:

indico-migrate 1.0.2 requires indico<2.1.dev0,>=2.0, but you'll have indico 2.3 which is incompatible.

Probably from when you migrated from indico 1.2 to 2.0. You’ll never need this tool again, so just get rid of it using pip uninstall -y indico-migrate (there are some leftovers like ZODB, but those are harmless to leave around)

Thanks. I will try tomorrow.

Thank you. I did it again. This time there was no error and no warning. It took only five minutes to upgade indico 2.2.5 to 2.3 in our case.

Extra commands

pip uninstall -y indico-migrate
pip install --upgrade pip


pip install -U indico
pip install -U indico-plugins
indico db upgrade
indico db --all-plugins upgrade

seem to be helpful. Thanks again!

Some other libs you can safely uninstall since they are only used by indico-migrate:

pip uninstall -y urwid ZODB3