LaTeXRuntimeException: Impossible to compile ( Happen in GUI interface)


#1

I need help.…the LaTex can’t compile pdf (book of abstracts) when i tried to open from GUI interface but running command seems to work (see below)

I clicked book of Abstract via conference overview - book of abstracts and LaTex failed to compile pdf

Unexpected error" error LaTeXRuntimeException: Impossible to compile ‘/opt/indico/tmp/indico-texgen-KWUhNS/book_of_abstracts.tpl.tex’. Read ‘/opt/indico/tmp/indico-texgen-KWUhNs/output.log’ for details"

**I run this command **

/opt/texlive/bin/x86_64-linux/xelatex -no-shell-escape -interaction nonstopmode -output-directory /opt/indico/tmp/indico-texgen-KWUhNS /opt/indico/tmp/indico-texgen-KWUhNS/book_of_abstracts.tpl.tex

It looks like it runs successfully

ABD: EveryShipout initializing macros
(/opt/texlive/texmf-dist/tex/generic/oberdiek/se-ascii-print.def) [1] [2]
[3] [4] (/opt/indico/tmp/indico-texgen-KWUhNS/book_of_abstracts.tpl.toc
(/opt/texlive/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/opt/texlive/texmf-dist/tex/latex/microtype/mt-msa.cfg)
(/opt/texlive/texmf-dist/tex/latex/amsfonts/umsb.fd)
(/opt/texlive/texmf-dist/tex/latex/microtype/mt-msb.cfg)
(/opt/texlive/texmf-dist/tex/latex/microtype/mt-cmr.cfg)) [5] [6]
Underfull \hbox (badness 10000) in paragraph at lines 200–201

Underfull \hbox (badness 10000) in paragraph at lines 385–386

[1] [2] [3] (/opt/indico/tmp/indico-texgen-KWUhNS/book_of_abstracts.tpl.aux) )
(see the transcript file for additional information)
Output written on /opt/indico/tmp/indico-texgen-KWUhNS/book_of_abstracts.tpl.pd
f (9 pages).

I checked /opt/indico/tmp/indico-texgen-KWUhNS and it got pdf file and tex file as well


#2

Did you check the following log file for the possible causes?


#3

I checked the /opt/indico/tmp/indico-texgen-KWUhNs/output.log but nothing is written

drwxr-x—. 2 indico apache 240 May 14 10:57 .
drwx–x—. 9 indico apache 4096 May 15 05:00 …
-rw-r-----. 1 root root 1756 May 14 12:37 book_of_abstracts.tpl.aux
-rw-r-----. 1 root root 54113 May 14 12:37 book_of_abstracts.tpl.log
-rw-r-----. 1 root root 917 May 14 12:37 book_of_abstracts.tpl.out
-rw-r-----. 1 root root 327852 May 14 12:37 book_of_abstracts.tpl.pdf
-rw-r-----. 1 indico apache 14314 May 14 10:48 book_of_abstracts.tpl.tex
-rw-r-----. 1 root root 789 May 14 12:37 book_of_abstracts.tpl.toc
-rw-r-----. 1 indico apache 0 May 14 10:48 output.log
-rw-r-----. 1 root root 832 May 14 10:55 texput.log


#4

Try to search for a possible cause in of those log files.


#5

What immedeatly looks strange are the owners here. Seems like tex runs as root and indico can not read the files ( mode rwr- for root:root, while indico is running as indico:apache)

As the tex run should not happen as root, check your setup carefully.


#6

That’s probably because he then ran it manually from the command line.

BTW @zmohamoud, you should not do those things as root - you can do pretty much everything related to indico as the indico user.


#7

Thank you guys. I must have installed LaTex under Root account . I will either have to reinstall app under indico or mod the permission. will let you know the result.


#8

I think there’s a misunderstanding: Installing texlive as root is correct. But to test if compiling the latex document works fine, you need to do it as the indico user. So I would recommend you to try accessing it in the browser again, and then go to the new folder created during the failed attempt and try running texlive manually there, but this time as the indico user.


#9

I run it via browser and then i went to failed folder and i run the command using indico user:

[indico@ip-10-200-136-76 tmp]$ /opt/texlive/bin/x86_64-linux/xelatex -no-shell-escape -interaction nonstopmode -output-directory /opt/indico/tmp/indico-texgen-OpAmli /opt/indico/tmp/indico-texgen-OpAmli/book_of_abstracts.tpl.tex
bash: /opt/texlive/bin/x86_64-linux/xelatex: Permission denied


#10

OK, in that case there’s indeed something wrong with your texlive setup. Did you by any chance change some permissions inside /opt/texlive?

Anyway, rm -rf /opt/texlive and reinstalling it based on the docs in https://docs.getindico.io/en/latest/installation/latex/ is probably the fastest way to (hopefully) get it working again.


#11

@ThiefMaster - I didn’t change ant permission on /opt/texlive. I removed the texlive and reinstalled based on installation guide in this link the https://docs.getindico.io/en/latest/installation/latex/#latex. Installed successful but then I tried o access abstract via browser and I get the same error;

Here is the default permission in /opt

drwx–x—. 13 indico apache 244 May 17 12:14 indico
drwxr-xr-x. 2 root root 103 Oct 3 2017 localuserlist
drwxr-x—. 8 root root 246 May 17 12:55 texlive

What is the right permission for indico user on /opt/texlive?


#12

I guess you have a restrictive umask set, so the default permissions of /opt/texlive were too strict.

chmod 755 /opt/texlive should fix it.