Issues installing python3-saml (lxml version mismatch)

I’ve some issues installing python3-saml via pip on my Indico test installation:

(indico) [indico@indico ~]$ pip install python3-saml
Collecting python3-saml
  Using cached python3_saml-1.14.0-py3-none-any.whl (76 kB)
Requirement already satisfied: xmlsec>=1.3.9 in ./.venv/lib/python3.9/site-packages (from python3-saml) (1.3.13)
Collecting lxml<4.7.1
  Using cached lxml-4.6.5-cp39-cp39-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (6.9 MB)
Requirement already satisfied: isodate>=0.6.1 in ./.venv/lib/python3.9/site-packages (from python3-saml) (0.6.1)
Requirement already satisfied: six in ./.venv/lib/python3.9/site-packages (from isodate>=0.6.1->python3-saml) (1.16.0)
Installing collected packages: lxml, python3-saml
  Attempting uninstall: lxml
    Found existing installation: lxml 4.9.1
    Uninstalling lxml-4.9.1:
      Successfully uninstalled lxml-4.9.1
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
indico 3.2 requires lxml[html5]==4.9.1, but you have lxml 4.6.5 which is incompatible.
Successfully installed lxml-4.6.5 python3-saml-1.14.0

I’m on CentOS 7 with Python v3.9.14 in the virtual env created for Indico.
It seems there is a conflict on the requirements, since Indico requires lxml == 4.9.1 and python3-saml requires the same package to be < 4.7.1.

Am I doing something wrong?

Thank you in advance for your time,

Oh great, they pin a max lxml version. Nothing you can do right now, I’ll open an issue with them asking if that pin is really needed since a library should NOT be pinning max versions in most cases.

Thank you very much!