Internal Server Error after LDAP configuration

I have an issue with the installation of Indico 3.0. I installed it following the “production installation instructions” with Apache and everything work fine. Then when I tried to add the configuration for LDAP I have the following error “Internal Server Error”. note that this LDAP configuration works with indico 2.3 without any issue. and the indico 3.0 works fine without LDAP configuration.

Anyone could help me to fix this issue? Where to search for this error.

_ldap_config = {
    'uri': '*************',
    'bind_dn': '*********',
    'bind_password': '************', 
    'timeout': 30,
    'verify_cert': True,
    'page_size': 1500,
    'uid': 'sAMAccountName',
    'user_base': '*************',
    'user_filter': '(sAMAccountName=*)',
    'gid': 'sAMAccountName',
    'group_base': '*****************', 
    'group_filter': '(sAMAccountName=*)',
    'member_of_attr': 'memberOf',
    'ad_group_style': False
    'cert_file': '*************'

    'ldap': {
        'type': 'ldap',
        'title': 'Local',
        'ldap': _ldap_config,
        'default': True

    'ldap': {
        'type': 'ldap',
        'title': 'LDAP',
        'ldap': _ldap_config,
        'mapping': {
            'first_name': 'givenName',
            'last_name': 'sn',
            'email': 'mail',
            'affiliation': 'department',
            'phone': 'telephoneNumber'
        'trusted_email': True,
        'default_group_provider': True,
        'synced_fields': {'first_name', 'last_name', 'email', 'affiliation', 'phone'}

You have a syntax error in the config file - there needs to be a , after 'ad_group_style': False

Tip: Trying to run indico shell is an easy way to see errors during startup.

1 Like

Thanks, I fixed it, and everything work fine.