Internal Server Error after installation

I’ve some issues with a test installation of Indico. I installed it following the so-called “production installation instructions” with Apache.
By the way, the following command doesn’t work anymore (error 404):
yum install -y
I’ve used this one:
yum install

I’ve created a VM with Centos7 (minimal install) and at the end of the installation of Indico I obtain an Internal Server Error 500 when I point the browser to https://IP_ADDRESS.
I also noticed that uwsgi causes peaks of 100% of cpu load.

Here below is the output of /var/log/httpd/error_log:

AH00112: Warning: DocumentRoot [/var/empty/apache] does not exist
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 
fe80::a00:27ff:fe15:a393. Set the 'ServerName' directive globally to suppress this message
[Tue May 19 20:10:45.275784 2020] [lbmethod_heartbeat:notice] [pid 5662] AH02282: No slotmem 
from mod_heartmonitor
[Tue May 19 20:10:45.276906 2020] [ssl:warn] [pid 5662] AH02292: Init: Name-based SSL virtual 
hosts only work for clients with TLS server name indication support (RFC 4366)
[Tue May 19 20:10:45.279407 2020] [mpm_prefork:notice] [pid 5662] AH00163: Apache/2.4.6 
(CentOS) OpenSSL/1.0.2k-fips configured -- resuming normal operations
[Tue May 19 20:10:45.279439 2020] [core:notice] [pid 5662] AH00094: Command line: 
'/usr/sbin/httpd -D FOREGROUND'

Here below the output of /var/log/httpd/ssl_error_log

[Tue May 19 20:10:45.137067 2020] [ssl:warn] [pid 5662] AH01909: RSA certificate configured for 
fe80::a00:27ff:fe15:a393:443 does NOT include an ID which matches the server name

Please, could you give me some hints?
Thank you in advance.

This should fix the problem.

Also, thanks for reporting the postgres install error. I’ll update our docs tomorrow.

I confirm that the fix seems to work fine. Now I can see the bootstrap phase of Indico on my browser.
Thank you very much for the help!

Docs are updated now.

Encountered same error but for Ubuntu Server. Error output same as pasted above.

Does the linked solution work for you? This is part of the setup docs though, so you should already have it…

The solution didn’t work for me. My resources were overloaded so I had to resize the instance in AWS. That caused the error I think.

I tried troubleshooting but things just got worse from that point. I have deleted the AWS instance and I’m starting reinstallation. I was actually concerned about the /var/empty/apache/.

Is it possible to create a virtual host manually and then just run certbot?

I’m not sure what you mean with creating a virtual host manually, but in principle our setup guides - especially when it comes to the webserver config - is just a suggestion that works for us. If you have experience configuring web servers you can of course adapt it as needed for your environment.

Sorry for the incorrect term. Not a computer guy actually.

I was wondering why just restarting the AWS instance could have caused this error.

Good questions, I never used AWS myself. If you get an Internal Server Error without any indico UI around it check if e.g. running indico shell as the indico user also results in an error - that’s usually the easiest way to see if something is broken in general