Installation problem, development environment

I am installing on a clean (just installed) Ubuntu 18.04(.3), and following the instructions for installation for development on the indico site.
All goes exactly as expected up to the step:

“pip install -e .”

at which point I get an ERROR:
ERROR: Package ‘indico’ requires a different Python: 2.7.17 not in ‘~=3.9’

The default Python is indeed 2.7.17, and I am stumped.
Any helpful ideas?
Thanks,

Use the 2.3-maintenance branch if you want to develop on the stable version. master is for Indico 3 which requires Python 3.9.

Thanks for that helpful hint.

This opens up a lot of questions, however, about the feasibility of developing
agains the stable (2.3) version:
-is version 3 coming soon (ie. within the next 6 months)?
-are there structural differences between versions 2.3 and 3 that would render
any halfway (or even fully) developed 2.3-plugins useless?

  • etc.

Nobody wants to waste time developing for /dev/null.

regards

is version 3 coming soon (ie. within the next 6 months)?

Certainly. More like within the next 2 months I hope.

are there structural differences between versions 2.3 and 3 that would render any halfway (or even fully) developed 2.3-plugins useless?

No. In fact, when porting the Zoom plugin this is all that needed to be changed. And the majority was fully automated by using modernize --no-diffs -n -w -x import vc_zoom/, then pyupgrade --py38-plus vc_zoom/**/*.py and some cleanups (removing unused six imports, isort, flake8) plus minor bugfixes (for some reason a case of viewitems() didn’t get automatically replaced with items()).