Indico not logging in after loggin out

Dear Support,

I am having an issue with Indico being unable to login. There was this error before I logged out : The Celery task scheduler does not seem to be running. This means that email sending and periodic tasks such as event reminders do not work.

Thanks in advance

Hi, this error has nothing to do with login issues (but if you are the one administrating the server, you should fix it, as it means that the background task daemon isn’t running - check systemctl status indico-celery.service to find out why, and possibly (re)start it).

Regarding your login issues, we need more details. Are you getting an error? Are you using local accounts, LDAP, or some kind of SSO?

There is no error. I input my credentials and it refreshes the page and does not recognize that I am logged in. When I try to go to the admin side of Indico it requests me to log in again.

Please see the results for systemctl status indico-celery

Is Redis running? If redis isn’t working then that’d explain why login doesn’t work (needs sessions which are stored in redis)…

Also check indico.log for any errors (and messages related to your login attempts).

There is no error in indico.log. How do I check if Redis is running?

What other messages are there regarding your login?

systemctl status redis.service

Here are the results.

Doesn’t seem to be running. Restart it.

I have tried to restart it but got no response from the terminal. I have been waiting for a couple of minutes now.

Sounds like something is stucked. Try kill -9 1598

Now the loggin part is working and the Celery error is still at the top. Another thing is when I try to check registrants list in a conference it gives me an error “500 INTERNAL SERVER ERROR”.

You need to restart Celery. If redis was stuck, there’s a good chance Celery isn’t working properly since it uses Redis internally to track its state.

If you get a 500 error, check indico.log for details.

Tried everything now getting this error when starting Redis.

Your output is truncated. You need to fix whatever is causing the “can’t open pid file” error…

I have managed to clear the error by adding the following:

nano /etc/systemd/system/redis.service

ExecStop=/bin/kill -s TERM $MAINPID
ExecStartPost=/bin/sh -c "echo $MAINPID > /var/run/redis/"  

sudo systemctl daemon-reload
sudo systemctl enable redis-server
sudo systemctl restart redis.service

Redis is now running. The issue is now the Red Celery error on Indico.

Hi. I am not sure what is happening but the system is back to not logging in and the celery error is still showing. Can’t save attachments on Indico and can’t see the conference registration list.

I have no idea what’s so messed up on your system, and I don’t think this is something I can figure out remotely - it’s probably be easy to see what’s wrong when in front of a terminal, but otherwise it’s just wild guesses.

If pages are broken and you get an error, check indico.log - it usually contains a detailed error and traceback. In case uploading materials fails without an error that’s really strange for sure.