Indico 3.3.2 indico db prepare syntax error

Is your system locale not set to an UTF-8 based one by any chance? What’s the output of locale?

In any case, these commands should fix it:

su - postgres -c 'dropdb indico'
su - postgres -c 'createdb -O indico -T template0 -E UTF8 indico'
su - postgres -c 'psql indico -c "CREATE EXTENSION unaccent; CREATE EXTENSION pg_trgm;"'


Thanks a lot for this. Now our Indico for testing is web accessible! :slight_smile:

Our problem now is that we’re getting constant “‘ascii’ codec can’t decode byte 0xc3 in position 476: ordinal not in range(128)” mails, and we can’t configure rooms or almost anything in Indico.

I looked up the error and it seems to be related too UTF-8 twice encoding in Python. Do you know in which file we need to change something?

Thanks a lot again.

Same issue as here: Unable to create event

You should REALLY change your global LC_CTYPE to an UTF8-based locale (seriously, why are there still systems in the 2020s that do NOT use UTF8 by default?!), but setting the env var for both indico-celery.service and indico-uwsgi.service should do the job:


That was it!! Thanks a lot!! :smiley:

Hello again,

I’ve tried following the guide for upgrading Indico from v2.x to v3.x. When using the “indico db upgrade” command after restoring the dump from the old Postgre database, I get the following error (there are tons of lines before this with different “^^^^^” messages):

I tried looking up the link for the background of the error (Error Messages — SQLAlchemy 1.4 Documentation), but it gets me nowhere.

Duplicate of this thread, where I posted the solution: Problem migrating from 2.3.5 to 3.3.1 - #2 by ThiefMaster

Thanks a lot again, it worked!!