Error when trying to search for rooms to book

Hi there,
We’re getting this js error when searching for room bookings:

The error is triggered when we click on the Search:

Any ideas why it might be happening?

Which Indico version is that, and which locale are you using?

the latest, v3.3.1, en_CA is the locale

Strange, 10/04/2024 is not the correct format for en_CA. It should be 2024-04-10. But in any case, that’s just the display formatting…

Can you share the URL and query string when getting that error? Feel free to censor the domain name, I only care about the rest.

It’s an internal site:

ok that looks all fine. really strange. i wonder if it’s related to one of our libraries and indico itself using different versions of momentjs, and then expecting a different date format for some reason… but i don’t see why that would happen, considering that the string passed to the validation function is standard iso format.

are you running the python wheel from PyPI or a custom-built one? any non-standard plugins?

It’s just a regular production install on that server, not a development install. We do have our own custom plugins enabled on the site.
Our live site is still at version 3.2.9 using locale en_GB along with the same plugins. The room search does work well there.

Does your custom plugin contain any JS? Would you be able to share it with me (e.g. via a private github repo) so I can try to see if any JS code in there may be causing it and/or reproduce the issue?

You could also try and see if it also happens if you disable your custom plugin

No, we don’t have any js in our plugins

Anything else related to momentjs (search for moment in your code), e.g. in a script block inside a custom template?

and i just disabled all plugins, the same issue is happening

no, there isn’t any use of momentjs in our plugins

On note: Even though our local is set to en_CA … we are seeing the dd/mm/yyyy format in the date widgets. en_CA should look like the ISO format yyyy-mm-dd.

That’s weird, when i set en_CA I get this:


Which browse are you using?

I am using Chrome
This is our settings in indico.conf


just tested on Safari and FF and I get the same result

I meant the locale set for your current user/session, not the default locale of the instance :wink:



I actually just updated some setting there under My Preferences and got the date format to display correctly on the date input, but still get the same error when I Search