Error from xsendfile


in preperation for the new version i installed on debian 12 the newest indico version and migrate the archive, customdesign and postgresql dump (from centos7 live system).

But i still get Errors:

Permission denied: [client XXXXXX] xsendfile: cannot open file: /opt/indico/archive/event/990/images/5640-Screenshot_2024-04-02_150315.png, referer: https://XXXXXXXXX/event/990/manage/layout/images/ 

Ownership looks okay:

ls -l archive/event/990/images/
 -rwxrwxrwx 1 indico www-data   7033 May  6 10:57 5639-Open_now.PNG

The only solution to fix this was to give the archive / customdesign dir -R 777 access right, no other level helps. What i am mission in the instruction /migration

Best regards

xsendfile is handled by the web server, so you need to check under which user/group the webserver process is running, and then make sure that user (or more likely its group www-data) can access that file.

When checking permissions also look at any directory in between - it needs to have at least the x bit in order to access something inside. So if /opt/indico/archive is owned by indico:www-data, then it must have at least the g+x permission bit.

As root you can use something like sudo -u www-data ls -ld /opt/indico /opt/indico/archive .... to check those individual permissions.

thx for the idea i forget 755 on a subfolder.

Problem solved