Can't change the contribution submitters in the abstract settings

Hi there,
I wanted to change the contribution submitters in the abstract settings from only “speakers” to “speakers and authors”, when I changed it to speakers and authors and clicked save it says “Abstract submission settings have been saved” but when I opened the settings again I found it is actually didn’t change and the other authors not able to submit a contribution except the speakers (as that the default settings).
So, what is the solution to this problem?
Indico verstion is 3.1
thank you

This bug has been be fixed in 3.2.4 (not released yet but soon). So you will need to update. 3.2 is outdated anyway… :wink:

If you want to change it right now, you can simply apply this one-line patch from the PR that fixed it and reload the indico-uwsgi service afterwards:

diff --git a/indico/modules/events/abstracts/ b/indico/modules/events/abstracts/
index dd72aca9261..7c343f4e75a 100644
--- a/indico/modules/events/abstracts/
+++ b/indico/modules/events/abstracts/
@@ -121,6 +121,7 @@ class BOALinkFormat(RichEnum):
     'end_dt': DatetimeConverter,
     'modification_end_dt': DatetimeConverter,
     'allow_editing': EnumConverter(AllowEditingType),
+    'contribution_submitters': EnumConverter(SubmissionRightsType),

Thank you very much,
the patch solved the problem. By the way, I have Indico (v3.2.4-pre) installed for development and also, it suffers from the same problem, the patch worked for both v3.1 and v3.2.4-pre.

Are you sure you’re on a somewhat recent master? That exact patch is already in there!

If not, rebase to the latest master.

Yes, I’m sure the version is 3.2.4-pre

The version number is not that useful considering that 3.2.4-pre can be ANYTHING custom built off master - so likely your master is behind upstream quite a bit.