[Solved] CUSTOMIZATION_DEBUG not logging anything


I tried to expand the theme and stumbled over the CUSTOMIZATION_DEBUG option.
But when checking /opt/indico/log/indico.log nothing shows up.

I tried:

  • systemctl restart indico-celery
  • systemctl restart apache2
  • Reloading the web page with and without cache turned off

Is there something else I can try?


# Template Customization
CUSTOMIZATION_DIR = '/opt/indico/custom'

(All I wanted was adding two links to the footer…)

With those settings I would expect CUSTOMIZATION_DEBUG to work properly unless you configured something strange in logging.yaml… but you could try adding level: DEBUG to the loggers/indico entry in /opt/indico/etc/logging.yaml.

This may make your log much more spammy though, so I’d remove this again afterwards.


  level: DEBUG # was INFO
  handlers: [other]

    handlers: [debug, indico, email]
    handlers: [celery, email, stderr]

Still nothing. Is there any way I can force indico to re-read the configuration?
Is there any other point of configuration that may take precedence over the default one?
echo $INDICO_CONFIG gives nothing.

restarting uwsgi is all you need, and /opt/indico/etc/indico.conf is the correct file to edit - the env var is only needed if there’s no /opt/indico/.indico.conf symlink pointing to it

systemctl restart uwsgi did the trick. I feel this could be documented a bit more explicitly for people who are less familiar with web applications.

Oh, I just realized you wrote apache2 and not uwsgi in your first post… :man_facepalming:

And you are right, mentioning that restarting uwsgi (and usually indico-celery as well, even though it doesn’t matter here) after config changes etc would be a good idea.