Room booking: There was a database error while processing your request

Hey everyone!

Just installed Indico using the Ubuntu/Apache installation guide. I had to do a couple reinstalls because I wasn’t able to open the indico page using hostname but now that sorta works (I can open it through for some reason).

I get the page in a very weird format as seen below and I’m not honestly sure why:

More importantly it gives me a database error. I followed the guide point by point so I’m pretty sure I didn’t mess up there. I’m new to Indico so I’m not sure where to look what the error/issue is. Any help would be greatly appreciated.

Please let me know if I can add anything else to make the issue clearer.

Thank you!

Check the indico.log for the traceback. It would be nice if you could share the traceback with us.

Hey, thanks for replying!

I was able to fix it by just pretty much preparing the db from scratch using indico db prepare. I’m assuming the multiple installs I did broke something.
It’s good now, thank you!

1 Like

This may be a bit off topic so I apologize, but what can I do about the “html’ish” page? I’m using Firefox Developer Edition (71.0b3) but it still tells me to update my browser.

Weird, the database contents should never cause broken CSS (even on the error page).

Anyway, if you fixed it now it’s great. You might want to try accessing /somethinginvalid to make sure the (404) error page looks correct.

I think something is wrong with your CSS and/or JavaScript. Are you sure the aliases in your nginx/apache config are correct? Check your browser’s developer console for errors.

The outdated-browser message showing up, just like the broken styling in your screenshot, are usually caused by CSS/JS being broken.

Yeah I checked the config
Loads of errors in the console: though :cry:

Edit: I tried accessing an invalid route, it does show me an error but again in broken js/css

open one of those links from the errors and see what you actually get there…

Oh right sorry,

I get this for all the links:

Check the nginx/apache error log in /opt/indico/logs/... - something is likely wrong with the aliases used for serving the static files…

I was able to fix it!

First, in indico.conf, AliasMatch was linking to /opt/indico/web/static/... but it should’ve actually been /opt/indico/web/htdocs/static/...
Honestly don’t know how I missed that

I checked the logs and pretty much everything showed a (13)PermissionDenied because Apache wasn’t able to access the static files. So I chmod’d the static files and now I get a properly rendered page!

Thank you so much, I really appreciate it! Sorry if I was unbearable :sweat_smile:

Which version did you install, using which guide? There is no htdocs anymore in 2.2!

And there should be a symlink like this:

/opt/indico/web/static -> /opt/indico/.venv/local/lib/python2.7/site-packages/indico/web/static

I installed 2.1.9 because 2.2 would NOT work for me no matter what I tried. I tried to work around it for a couple of days and it just wouldn’t work so I went for 2.1.9 and it worked.
This is the guide I used but the only change I made was instead of pip install indico, I did pip install "indico==2.1.9".

I understand the guide was for 2.2.4 but yeah.

Ah, for 2.1.x you need to use this setup guide instead. The aliases there are slightly different there…
Also, you want pip install indico<2.2 to get the latest 2.1 version here as 2.1.9 contains known security issues.

However, if this is a new setup I would strongly recommend you to try again with 2.2. Using an outdated version will just lead to more trouble in the future (we do not backport bugfixes unless they are extremely important or security issues), and now would be the best time to start with the latest version…

Using the setup guide from it should work - if not, please let us know and we can likely help you figure out what’s wrong.

Since you mentioned that you made multiple attempts at installing everything before, I would recommend you to start from scratch, i.e. recreate the VM you are using so you don’t have any leftovers from the previous installs…