Room booking issue

Hello Indico Community,

i have an issue with the room booking plugin.
in a few words, when a user tries to access on the room booking,
this is the page visualized:

i tried with the “impersonate” a few accounts to access at the plugin and it’s very strange because some accounts can access and some not.

i looked the logs (Celery.log and Apache) nothing strange inside, But in indico.log i saw a difference between a user with issue and user without issue:

user log can access to the room booking:

2021-06-16 11:24:20,680 INFO ba4c69e4e2044f5b 578 indico.rh GET /user/search/?last_name=USER1&favorites_first=true [IP=XXX.XXX.XXX.XXX] [PID=31925] 2021-06-16 11:24:32,664 INFO 13f345fa96964eb5 578 indico.rh POST /admin/users/impersonate [IP=XXX.XXX.XXX.XXX] [PID=31919] 2021-06-16 11:24:32,722 INFO 99d6ff44c66b4f70 651 indico.rh GET /rooms/book [IP=XXX.XXX.XXX.XXX] [PID=31921] 2021-06-16 11:24:32,928 INFO df0de8cea62f4847 651 indico.rh GET /rooms/api/config [IP=XXX.XXX.XXX.XXX] [PID=31921] 2021-06-16 11:24:32,929 INFO aefdd82564b0479d 651 indico.rh GET /rooms/api/user/ [IP=XXX.XXX.XXX.XXX] [PID=31925] 2021-06-16 11:24:32,954 INFO 7c9b8951c2e2458b 651 indico.rh GET /rooms/api/rooms/permissions [IP=XXX.XXX.XXX.XXX] [PID=31919] 2021-06-16 11:24:32,954 INFO c346bbf52a8e4467 651 indico.rh GET /rooms/api/user/favorite-rooms/ [IP=XXX.XXX.XXX.XXX] [PID=31923] 2021-06-16 11:24:32,971 INFO 5ef8c9352301408d 651 indico.rh GET /rooms/api/rooms/ [IP=XXX.XXX.XXX.XXX] [PID=31921] 2021-06-16 11:24:32,979 INFO f0920629a5bf4edc 651 indico.rh GET /rooms/api/equipment [IP=XXX.XXX.XXX.XXX] [PID=31925] 2021-06-16 11:24:33,114 INFO 368d570f43924ea1 651 indico.rh GET /rooms/api/bookings/mine [IP=XXX.XXX.XXX.XXX] [PID=31921] 2021-06-16 11:24:33,188 INFO 966d9e9f8c764b1f 651 indico.rh GET /rooms/api/stats [IP=XXX.XXX.XXX.XXX] [PID=31925]

user log can’t access to the room booking:

`2021-06-16 11:25:31,609 INFO f8b89f7c228c4486 578 indico.rh GET /user/search/?last_name=USER2&favorites_first=true [IP=XXX.XXX.XXX.XXX] [PID=31923]
2021-06-16 11:25:34,010 INFO d44c275bed3448f5 578 indico.rh POST /admin/users/impersonate [IP=XXX.XXX.XXX.XXX] [PID=31921]
2021-06-16 11:25:34,087 INFO 79f1c8cdb48a445e 277 indico.rh GET /rooms/book [IP=XXX.XXX.XXX.XXX] [PID=31925]
2021-06-16 11:25:34,342 INFO 6b89bcc77037422e 277 indico.rh GET /rooms/api/config [IP=XXX.XXX.XXX.XXX] [PID=31925]
2021-06-16 11:25:34,345 INFO ff008e2debcb4113 277 indico.rh GET /rooms/api/user/ [IP=XXX.XXX.XXX.XXX] [PID=31921]
2021-06-16 11:25:34,346 INFO d7290cc37c7f4ed7 277 indico.rh GET /rooms/api/user/favorite-rooms/ [IP=XXX.XXX.XXX.XXX] [PID=31919]
2021-06-16 11:25:34,389 INFO ecc4498b63094c97 277 indico.rh GET /rooms/api/rooms/permissions [IP=XXX.XXX.XXX.XXX] [PID=31919]
2021-06-16 11:25:34,390 INFO 6781a8aee25b4b24 277 indico.rh GET /rooms/api/rooms/ [IP=XXX.XXX.XXX.XXX] [PID=31923]
2021-06-16 11:25:34,391 INFO 89b2920e71f04f26 277 indico.rh GET /rooms/api/equipment [IP=XXX.XXX.XXX.XXX] [PID=31925]

these two lines are missing in the log of the user doesn’t have access:

2021-06-16 11:24:33,114 INFO 368d570f43924ea1 651 indico.rh GET /rooms/api/bookings/mine [IP=XXX.XXX.XXX.XXX] [PID=31921]
2021-06-16 11:24:33,188 INFO 966d9e9f8c764b1f 651 indico.rh GET /rooms/api/stats [IP=XXX.XXX.XXX.XXX] [PID=31925]`

i tried many things:

  • put the user on the admin group
  • put the user in a new group(group with access rights at the room booking)
  • put directly the user in the “whitelist”

nothing works

My config:

Indico 2.3.4
indico plugin 2.3.1
CentOS 7
pip 20.3.4
Python 2.7

Can you help me please?
Thank’s in advance

Hi, check the browser’s JS error console. If it’s stuck in “loading” state there’s a very good chance that some JS error is breaking it.

indeed, I have an error:

this error only concerns accounts that do not have access to the room booking,
for the other account no error

Many thanks in advance,

There is no en-us locale in Indico; switch the language to something else and then back to english to fix it for yourself; and ideally run this script in indico shell to make sure no user has this invalid locale:

Also, in case you use en_US as the default language in indico.conf, change it to en_GB.

after script execution , the output is :

Incorrect versions of uk_UA: 0
Incorrect versions of fr_FR: 0
Incorrect versions of pt_BR: 0
Incorrect versions of es_ES: 0
Incorrect versions of en_GB: 0
Incorrect versions of zh_Hans_CN: 0
Invalid locales: 499 (en_US)

now all account have a good localization

Thanks again for the incredibly quick help.