LaTeXRuntimeException


#1

I tried to open pdf for submitted abstract and I get this error:

LaTeXRuntimeException: Impossible to compile ‘/opt/indico/tmp/indico-texgen-gfg8eX/single_doc.tpl.tex’. Read ‘/opt/indico/tmp/indico-texgen-gfg8eX/output.log’ for details

I checked the log but nothing is written in the log file


#2

Did you install and configure texlive?


#3

I though installation of texlive is part of installation guide of LaTex https://docs.getindico.io/en/stable/installation/latex/. I installed LaTex with version 2.1.7 then i had to upgrade to 2.1.8 to fix issue with celery task scheduler not running. Do i need reinstall LaTex?


#4

No, if you followed that part of the guide then it should work. What happens if you try to run /opt/texlive/bin/x86_64-linux/xelatex manually from the shell?


#5

I run it manually and it kept asking type name of your input file:

$ /opt/texlive/bin/x86_64-linux/xelatex
This is XeTeX, Version 3.14159265-2.6-0.99999 (TeX Live 2018) (preloaded format=xelatex)
 restricted \write18 enabled.
**
Please type the name of your input file.
**
Please type the name of your input file.

#6

That’s fine, I just wanted to rule out any errors like missing libraries.

Check if there are any other log files in /opt/indico/tmp/indico-texgen-gfg8eX that might have some clues on why it failed.


#7

the output log is empty


#8

Try running it manually:

/opt/texlive/bin/x86_64-linux/xelatex -no-shell-escape -interaction nonstopmode -output-directory /opt/indico/tmp/indico-texgen-gfg8eX /opt/indico/tmp/indico-texgen-gfg8eX/*.tex

Replace *.tex with the actual .tex filename in there.


#9

/opt/texlive/bin/x86_64-linux/xelatex -no-shell-escape -interaction nonstopmode -output-directory /opt/indico/tmp/indico-texgen-gfg8eX /opt/indico/tmp/indico-texgen-gfg8eX/single_doc.tpl.tex
This is XeTeX, Version 3.14159265-2.6-0.99999 (TeX Live 2018) (preloaded format=xelatex)
fatal: memory exhausted (xmalloc of 85227664 bytes).


#10

OK, weird. Is this a particularly big abstract? I don’t see how it would use too much memory otherwise…

Anyway, now that you have an error try googling for it latex "fatal: memory exhausted" would be my suggestion to put in Google. FWIW, I never encountered that error myself (and I don’t remember anyone in the team ever having such a problem either) so I’d have to start googling for it as well.

If you do not find a solution, zipping the contents of the indico-texgen-gfg8eX folder and uploading it here (assuming it contains no sensitive information) could be helpful as it’d allow others to see if they have the same problem.


#11

It is not real abstract rather indico user guide that we are using to test setting up the conference . I was able to uploaded but then exp. The file is indico user guide (about 6.6MB.)

in this screen i can upload and open it -


#12

I’m not sure I understand your answer - how is this “indico user guide” pdf related to your problem? What data did you put in the “content” of the abstract?


#13

I was using that file to test upload and see if conference participator can open it from indico link. I also want to ensure that Latex is installed properly.
If you think it LATEx installation is good, then the issue is user error (new indico) . In mean time i will recreate the whole scenario and let you know how it goes.


#14

I forget to answer your last question. I enter sample text in content text box in Submit new abstract then when i tried to export to pdf i got some errors:
see screen shot below:


#15

Possibly: https://tex.stackexchange.com/questions/438902/how-to-increase-memory-size-for-xelatex-in-miktex ?