JS error when selecting user to login as or add to favourite

I’m getting this JS error when selecting a user to add to favourite users:

[Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive. See https://www.chromestatus.com/features/6662647093133312
preventDefault @ jquery.2f374269.bundle.js:formatted:38643
dispatch @ jquery.2f374269.bundle.js:formatted:38535
x.handle @ jquery.2f374269.bundle.js:formatted:38473

The user is added after refresh.

Also, when I want to search for a user to impersonate I get this JS error:

Uncaught TypeError: Cannot read property '23' of undefined
    at create_favorite_button (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:22:44)
    at Object._drawItem (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:112:38)
    at eval (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:254:71)
    at Object.inserter [as itemAdded] (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:325:19)
    at observer (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:157:29)
    at Invoke (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:30:44)
    at enumerate (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:51:5)
    at Object.each (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:28:18)
    at eval (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:54:22)
    at Object.append (eval at n.exports (main.f4c2ccbb.bundle.js:1), <anonymous>:101:7)

The user list is empty although ajax response contains the user. As a result, I cannot impersonate any user. I was able to impersonate a user before.

Any help would be appreciated

Which Indico version are you using? Can you share the link to your Indico instance?

1 Like

version v2.3
link: https://events.uobaghdad.edu.iq/

Can you open this URL and paste the contents you get?

PS: v2.3 is outdated. Please update to v2.3.3.


Yes, I plan to update.

Are you logged in? Because that’s what the file usually contains when you aren’t logged in… but in that case you should not see the user impersonation menu!

I’m logged in. I tried logging out and in again, same output.

Press CTRL-F5 when viewing that file. Do you still get that same output?

Same output. I also logged in using another user and got the same output.


I used VPN and everything is working fine. It looks like a network issue (we have got a very bad internet service here in Iraq). It’s my fault for forgetting to try this first.
Thank you very much for your time.

One last question:

Does upgrading from 2.3 to 2.3.3 require some specific steps or I just follow the steps in following link?


Just those steps.

However, in the (hopefully unlikely!) case that you get some JS errors afterwards (or if you want to be on the safe side), run the script from this post in indico shell.

1 Like