Internal server error

I’ve got an issue when i’m trying to connect on my page.
It seems to be an issue from uwsgi.
While running systemctl status uwsgi it shows:
uwsgi[8623]: — no python application found, check your startup logs for errors —

Any idea?

Do you get any errors when running e.g. indico shell?

Yes i’ve got this,

Traceback (most recent call last):
  File "/opt/indico/.venv/bin/indico", line 8, in <module>
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 829, in __call__
    return self.main(*args, **kwargs)
  File "/opt/indico/.venv/lib/python2.7/site-packages/flask/", line 586, in main
    return super(FlaskGroup, self).main(*args, **kwargs)
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 782, in main
    rv = self.invoke(ctx)
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 1259, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 1066, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 610, in invoke
    return callback(*args, **kwargs)
  File "/opt/indico/.venv/lib/python2.7/site-packages/click/", line 21, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "/opt/indico/.venv/lib/python2.7/site-packages/flask/", line 425, in decorator
    with __ctx.ensure_object(ScriptInfo).load_app().app_context():
  File "/opt/indico/.venv/lib/python2.7/site-packages/flask/", line 381, in load_app
    app = call_factory(self, self.create_app)
  File "/opt/indico/.venv/lib/python2.7/site-packages/flask/", line 117, in call_factory
    return app_factory(script_info)
  File "/opt/indico/.venv/lib/python2.7/site-packages/indico/cli/", line 28, in _create_app
    return make_app(set_path=True)
  File "/opt/indico/.venv/lib/python2.7/site-packages/indico/web/flask/", line 361, in make_app
  File "/opt/indico/.venv/lib/python2.7/site-packages/indico/core/", line 154, in init
  File "/usr/lib64/python2.7/logging/", line 803, in dictConfig
  File "/usr/lib64/python2.7/logging/", line 585, in configure
    '%r: %s' % (name, e))
ValueError: Unable to configure handler 'celery': [Errno 13] Permission denied: u'/opt/indico/log/celery.log'

Sounds like the permissions on that file are wrong. Maybe it’s owned by root instead of the indico user for some reason?

I’ve just reinstall indico, and it works now.
I didn’t know why this error was here because yesterday everything works.
Thanks anyway

Reinstalling was probably a bit of overkill but as long as it works now… :wink: